$re = '/[0-9]{1,2}:[0-9][0-9]\s*[aApP]\.*[mM]\.*/m';
$str = '07:30 a.m.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);