import Foundation
let pattern = #"\<hr\>([\s\S]*?(?=\n.*?i>))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<!-- Mirrored from www.telephone-exchange.co.uk/Abbeyhill-ESABB.html by HTTrack Website Copier/3.x [XR&CO'2014], Thu, 03 Jun 2021 05:14:37 GMT -->
<!-- Added by HTTrack --><meta http-equiv="content-type" content="text/html;charset=UTF-8" /><!-- /Added by HTTrack -->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Abbeyhill Telephone Exchange. Network ID (ESABB)</title>
<meta name="description" content="Telephone & broadband services available from the Abbeyhill Telephone Exchange (ESABB)" />
<link href="style2.css" rel="stylesheet" type="text/css" />
<script language="javascript" type="text/javascript">
function clearText(field)
{
if (field.defaultValue == field.value) field.value = '';
else if (field.value == '') field.value = field.defaultValue;
}
</script>
<!--[if lt IE 6]>
<style type="text/css">
img { behavior: url(iepngfix.htc); }
</style>
<![endif]-->
<style type="text/css">
/*<![CDATA[*/
strong.c2 {text-decoration: underline}
a.c1 {text-decoration:none;}
/*]]>*/
table {
font-family: arial, sans-serif;
border-collapse: collapse;
width: 100%;
}
td, th {
border: 1px solid #dddddd;
text-align: center;
padding: 5px;
}
tr:nth-child(even) {
background-color: #dddddd;
}
table.center {
margin-left:auto;
margin-right:auto;
}
</style>
</head>
<body>
<div id="background_section_top">
<div class="container">
<div id="logo_section">
<img src="images/logo3.png" alt="Telephone Exchange" title="Telephone Exchange" border="0" />
</div>
<div id="search_box">
<b>Check The Broadband Speeds For Your Landline</b><br />
<form action="https://www.telephone-exchange.co.uk/speed-test.php" method="get">
<input type="text" name="TelNo" value="Enter Your BT Phone Number" id="textfield" onfocus="clearText(this)" onblur="this.value=removeSpaces(this.value)"/>
<input type="submit" value="Speed Check" alt="Speed Check" id="button" title="Speed Check" />
</form>
</div>
<div id="menu_section">
<ul>
<li><a href="index.html">Home</a></li>
<li><a href="about.html">About</a></li>
<li><a href="cookie.html">Cookie Policy</a></li>
<li><a href="contact.html">Contact</a></li>
<li><a href="privacy.html">Privacy Policy</a></li>
<li><a href="sitemap.html">Site Map</a></li>
</ul>
</div>
</div>
</div><!-- End Of Top Background -->
<div id="background_section_mid">
<div class="container">
<div id="content_area">
<div id="left_section">
<div class="left_section_box">
<div class="left_section_box_top">Abbeyhill Telephone Exchange</div>
<div class="left_section_box_body">
<h2>Fibre Enabled</h2><p><a href="https://www.awin1.com/cread.php?s=455617&v=3041&q=210527&r=21479"><img src="images/BT_Logo.jpg" alt="BT Logo" title="BT Logo"></a>
Fibre to the Cabinet, Fibre to the Premises & Fibre on Demand services are available to customers connected to the Abbeyhill exchange. Most customers can now upgrade from ADSL to fibre internet. Suppliers include <a href="https://www.awin1.com/cread.php?s=455617&v=3041&q=210527&r=21479" rel="nofollow" target="_blank"><b>BT Superfast Fibre</b></a>, <a href="https://www.awin1.com/cread.php?s=2693173&v=2973&q=394873&r=21479" rel="nofollow" target="_blank"><b>Plusnet Fibre Broadband</b></a>, <a href="https://www.awin1.com/cread.php?s=2295377&v=3674&q=352341&r=21479" rel="nofollow" target="_blank"><b>TalkTalk Fast Broadband</b></a>, <a href="https://www.awin1.com/cread.php?s=2186410&v=4260&q=339996&r=21479" rel="nofollow" target="_blank"><b>John Lewis Broadband</b></a> & <a href="https://www.awin1.com/cread.php?s=552665&v=3516&q=189613&r=21479" rel="nofollow" target="_blank"><b>ee Unlimited Fibre Broadband</b></a></p><hr /><p><b>BT Line Rental - 12 Months For The Price Of 11</b><br />
Line Rental Saver from BT allows you pay your home telephone line rental for an entire year by credit/debit card payment and receive 1 months rental free. <a href="https://www.awin1.com/cread.php?s=455617&v=3041&q=210527&r=21479" target="_blank" rel="nofollow"><b>Line Rental Saver</b></a></p>
<p>County, District or Unitary Authority = City of Edinburgh Council.</p><hr><p>UK dialling code (STD code) for the Abbeyhill exchange is 0131</p>
<hr>
<p>The Abbeyhill exchange is in the Edinburgh group of exchanges.</p><p>25 telephone exchanges form this regional grouping.</p><hr>
<p>Edinburgh Abbeyhill</p>
<hr>
<h2>Exchange Address</h2>
<p>Located at :-<br />
British Telecom,<br />
Telephone Exchange,<br />
65-69 London Road,<br />
EDINBURGH.<br />
EH7 6AA</p>
<p> -> Edinburgh City -> Scotland</p>
<p><i>See Location Map Below</i></p>
<h2 class="heading">Exchange Location</h2>
<iframe width="380" height="300" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="https://maps.google.com/maps?f=q&source=s_q&hl=en&geocode=&q=%20Exchange@55.955519,-3.157307&ie=UTF8&z=15&t=h&iwloc=near&output=embed"></iframe><br /><br />
<iframe width="380" height="300" frameborder="0" src="https://www.bing.com/maps/embed?h=300&w=380&cp=55.955519~-3.157307&lvl=18&typ=d&sty=h&src=SHELL&FORM=MBEDV8" scrolling="no"></iframe>
<a id="largeMapLink" target="_blank" href="https://www.bing.com/maps?cp=55.955519~-3.157307&sty=h&lvl=14&FORM=MBEDLD">View Larger Map</a> |
<a id="dirMapLink" target="_blank" href="https://www.bing.com/maps/directions?cp=~&sty=h&lvl=14&rtp=~pos.&FORM=MBEDLD&pushpins=-3.157307">Get Directions</a>
</div>
</div>
<div class="cleaner"></div>
</div>
</div>
<!-- End Of left Section -->
<div id="middle_section">
<div class="middle_section_box">
<h1>Openreach Identifer</h1>
<ul>
<li>Network identifier code for the exchange is <b>ESABB</b></li>
</ul>
</div>
<div class="middle_section_box">
<h1>Your LLU Services</h1>
<a href="https://www.awin1.com/cread.php?s=2295377&v=3674&q=352341&r=21479" target="_blank"><img src="images/talktalk.png" alt=" Telephone Exchange, Abbeyhill (ESABB) has been unbundled by TalkTalk" title="Telephone Exchange, Abbeyhill (ESABB) has been unbundled by TalkTalk" border="0" /></a><br />
</div> <div class="middle_section_box">
<h1>Static IP Address</h1>
<ul>
<li><a href="https://www.awin1.com/cread.php?s=2693173&v=2973&q=394873&r=21479" target="_blank">Plusnet</a> offer their broadband customers the option of a "Static IP Address" for a one off charge of just £5. Make reliable VoIP calls, run a server, host a website or monitor CCTV remotely with a "Static IP Address" from <a href="https://www.awin1.com/cread.php?s=2693173&v=2973&q=394873&r=21479" target="_blank">Plusnet</a></li>
</ul>
</div>
<div class="middle_section_box">
<h1>Fibre To The Cabinet</h1>
<ul>
<li>The Abbeyhill exchange provides fibre services.</li>
</ul>
</div>
<div class="middle_section_box">
<h1>21CN WBC</h1>
<ul>
<li>This exchange is 21CN WBC enabled</li>
</ul>
</div>
<div class="middle_section_box">
<h1>ADSL Max</h1>
<ul>
<li>The Abbeyhill exchange has been enabled for ADSL Max since March 2006</li>
</ul>
</div>
<div class="middle_section_box">
<h1>ADSL</h1>
<ul>
<li>The Abbeyhill telephone exchange in Edinburgh City was enabled for ADSL in March 2001</li>
</ul>
</div>
<div class="middle_section_box">
<h1>Ofcom Classification</h1>
<ul>
<li>The BT exchange, Abbeyhill is classified by Ofcom as:- Market 3.</li>
</ul>
</div>
</div><!-- End Of Middle Section -->
<div id="right_section">
<div class="right_section_box">
<!-- START ADVERTISER: EE Home Broadband from awin.com -->
<a href="https://www.awin1.com/cread.php?s=552253&v=3516&q=189775&r=21479">
<img src="https://www.awin1.com/cshow.php?s=552253&v=3516&q=189775&r=21479" border="0">
</a>
<!-- END ADVERTISER: EE Home Broadband from awin.com -->
</div>
<div class="right_section_box">
<h1>PSTN Network Switch Off In 2025</h1>
<p>The first stage Openreach propose to facilitate the retirement of their public switched telephone network (PSTN) is to issue 'Stop Sell' dates for specific telephone exchanges. Once a 'Stop Sell' date has passed, communication providers (CP's) will be unable to order any copper based products if a fibre solution is available at the customer's premises. Accepted fibre solutions include FTTP and SOGEA/SOGFast.</p>
<p>Impacted product and services that will be unavailable beyond a 'Stop Sell' date include WLR3 analogue, ISDN 2, ISDN 30, LLU SMPF, SLU SMPF, Narrowband Line Share and Classic products. Additionally, 'Bandwidth Changes' to FTTC (VDSL2) will not be allowed beyond the 'Stop Sell' date. As an example, customers will be unable to move from 40/10 to 80/20 profiles once the 'Stop Sell' date has passed.</p>
<p>Openreach have identified 298 specific 'FTTP Priority Exchanges' that will be the first to receive 'Stop Sell' notices, see below.</p>
<p><b>Openreach declared the Abbeyhill Exchange, City of Edinburgh as a 'FTTP Priority Exchange' and issued a 'Stop Sell' notice effective from Tuesday 29th June 2021</b></p>
</div>
<div class="right_section_box">
<h1>BT Wholesale Suppliers</h1>
<h3><a href="https://www.awin1.com/cread.php?s=455617&v=3041&q=210527&r=21479" target="_blank"><img src="img/green_tick.png" alt="BT Broadband & Mobile" title="BT Broadband & Mobile" /> BT Broadband & Mobile</a></h3>
<h3><a href="https://www.awin1.com/cread.php?s=552665&v=3516&q=189613&r=21479" target="_blank"><img src="img/green_tick.png" alt="EE Home Broadband" title="EE Home Broadband" /> EE Home Broadband</a></h3>
<h3><a href="https://www.awin1.com/cread.php?s=2186410&v=4260&q=339996&r=21479" target="_blank"><img src="img/green_tick.png" alt="John Lewis Broadband" title="John Lewis Broadband" /> John Lewis Broadband</a></h3>
<h3><a href="https://www.awin1.com/cread.php?s=2693173&v=2973&q=394873&r=21479" target="_blank"><img src="img/green_tick.png" alt="Plusnet" title="Plusnet" /> Plusnet</a></h3>
</div>
<div class="right_section_box">
<h3><img src="img/green_tick.png" alt="LLU services from TalkTalk are available from this exchange" title="LLU services from TalkTalk are available from this exchange" /> TalkTalk</h3><h3><img src="img/green_tick.png" alt="LLU services from Sky are available from this exchange" title="LLU services from Sky are available from this exchange" /> Sky</h3></div>
</div><!-- End Of right Section -->
<div class="cleaner_with_height"> </div>
</div>
<!-- End Of content area -->
<div id="footer">
Copyright © 2021 Computerdeal Limited
</div><!-- End Of container -->
</div><!-- End Of Middle Background -->
</body>
<!-- Mirrored from www.telephone-exchange.co.uk/Abbeyhill-ESABB.html by HTTrack Website Copier/3.x [XR&CO'2014], Thu, 03 Jun 2021 05:14:41 GMT -->
</html>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)