using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"‘(?:(?![.,?!]’)[^’]){230,}";
string input = @"this is a test ‘quote here quote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote 'Charles's horse' herequote herequote herequote herequote herequote herequote herequote .herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote here’
this is a test ‘quote here quote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote 'Charles's horse' herequote herequote herequote herequote herequote herequote herequote .herequote herequote!’ herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote here’";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}