$re = '/http:\/\/(?<url>[^\.]+)/m';
$str = 'http://03131bipc142w.za.sbicdirectory.com:444/grid/console';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);