$re = '/\b(?<!num{)(?<!SI{)\d+,\d+/m';
$str = '2,47
12,67
\\mathbf{12,76}
\\num{2,76}
\\num{12,76}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);