re = /^.*\/([a-z0-9]+).*\.jpg$/m
str = 'https://image/4x/c1/abc/5b026cdb06921e7ca5f7a24aff46512e--wedding-vendors-wedding-receptions.jpg
https://image/4x/c1/abc/5b026cdb06921e7ca5f7a24aff46512e.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end