$re = '/^(?:[a-zA-Z]:\\\\|\\\\\\\\)([^\\\\\/\:*?<>"|]+\\\\?)+$/';
$str = 'c:\\12\\34\\aaaaaaaaaaaaaaaaaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);