import re
regex = re.compile(r".*\"profile-info\">\s*(.*?)\s*<\/div>.*\"post-content\">\s*(.*?)\s*<\/div>.*", flags=re.DOTALL | re.MULTILINE)
test_str = ("<html>\n"
" <head>\n"
" <head>\n"
" <body>\n"
" <div class=\"content\">\n"
" <div class=\"profile-info\">\n"
" bla bla\n"
" </div>\n"
" <div class=\"post-content\">\n"
" blabla\n"
" </div>\n"
" </div>\n"
" </body>\n"
"</html>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")