import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p>([А-ЯҐЄІЇа-яєії -]+)\\s<b>([\\w\\.]+@[\\w\\.]+)";
final String string = "<h2> <span class=\"mw-headline\" id=\"1..09.D0.9D.D0.B0.D0.B2.D1.87.D0.B0.D0.BB.D1.8C.D0.BD.D0.BE-.D0.BD.D0.B0.D1.83.D0.BA.D0.BE.D0.B2.D0.B8.D0.B9_.D1.86.D0.B5.D0.BD.D1.82.D1.80\"> 1. Навчально-науковий центр </span></h2>\n"
+ "<p>Директор навчально-наукового центру <b>director_rc@vsau.vin.ua</b>\n"
+ "</p><p>Навчальний відділ <b>docs@vsau.vin.ua</b>\n"
+ "</p><p>Відділ практичного навчання та працевлаштування <b>pr_tr@vsau.vin.ua</b>\n"
+ "</p><p>Відділ автоматизації розкладу та формування навчального навантаження <b>auto_form@vsau.vin.ua</b>\n"
+ "</p><p>Відділ функціонування та удосконалення обслуговуючих навчальних програм <b>inform@vsau.vin.ua</b>\n"
+ "</p><p>Науково-методичний відділ <b>scie_method@vsau.vin.ua</b>\n"
+ "</p><p>Науково-дослідна лабораторія біоенергетики <b>res_lab_bio@vsau.vin.ua</b>\n"
+ "</p>\n"
+ "<h2> <span class=\"mw-headline\" id=\"2..09.D0.9F.D1.80.D0.BE.D1.80.D0.B5.D0.BA.D1.82.D0.BE.D1.80.D0.B8\"> 2. Проректори </span></h2>\n"
+ "<p>Перший проректор <b>dep_rector@vsau.vin.ua</b>\n"
+ "</p><p>Проректор з науково-педагогічної та навчальної роботи <b>rector_education@vsau.vin.ua</b>\n"
+ "</p><p>Проректор з науково-педагогічної та фінансово-економічної роботи <b>dep_rector1@vsau.vin.ua</b>\n\n"
+ "</p>\n"
+ "<h2> <span class=\"mw-headline\" id=\"3..09.D0.94.D0.B5.D0.BA.D0.B0.D0.BD.D0.B0.D1.82.D0.B8\"> 3. Деканати </span></h2>\n"
+ "<p>Економічний факультет <b>fin_econ@vsau.vin.ua</b>\n"
+ "</p><p>Факультет механізації сільського господарства <b>engineering@vsau.vin.ua</b>\n"
+ "</p><p>Факультет менеджмету та права <b>managers@vsau.vin.ua</b>\n"
+ "</p><p>Агрономічний факультет <b>agronomy@vsau.vin.ua</b>\n"
+ "</p><p>Факультет технології виробництва та переробки продукції тваринництва <b>stockbreeding@vsau.vin.ua</b>\n"
+ "</p>\n"
+ "<h2> <span class=\"mw-headline\" id=\"4._.D0.95.D0.BA.D0.BE.D0.BD.D0.BE.D0.BC.D1.96.D1.87.D0.BD.D0.B8.D0.B9_.D1.84.D0.B0.D0.BA.D1.83.D0.BB.D1.8C.D1.82.D0.B5.D1.82\"> 4. Економічний факультет</span></h2>\n"
+ "<p>Кафедра економічної кібернетики <b>ec_cybernetics@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра міжнародної економіки <b>intern_economy@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра фінансів та кредиту <b>fin_credit@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра вищої математики, інформатики та математичних методів в економіці <b>mathematics@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра обліку та аналізу <b>account_analis@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра організації обліку та звітності <b>account_report@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра аудиту та державного контролю <b>dcontrol@vsau.vin.ua</b>\n"
+ "</p><p><br />\n"
+ "</p>\n"
+ "<h2> <span class=\"mw-headline\" id=\"5._.D0.90.D0.B3.D1.80.D0.BE.D0.BD.D0.BE.D0.BC.D1.96.D1.87.D0.BD.D0.B8.D0.B9_.D1.84.D0.B0.D0.BA.D1.83.D0.BB.D1.8C.D1.82.D0.B5.D1.82\"> 5. Агрономічний факультет </span></h2>\n"
+ "<p>Кафедра ботаніки генетики та фізіології рослин <b>plant_physiology@vsau.vin.ua</b>\n"
+ "</p><p>Кафера екології та охорони навколишнього середовища <b>ekology@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра землеробства,грунтознавства та aгрохімії. <b>soil_science@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра ліснового, садово-паркового господарства та кормовиробництва <b>forest_fodder@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра плодівництва, овочівництва, та технологій зберігання і переробки сільськогосподарської продукції <b>vegetable@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра рослинництва, селекції та біоенергетичних культур <b>plant_science@vsau.vin.ua</b>\n"
+ "</p><p>Наукова вимірювальна агрохімічна лабораторія кафедри екології та охорони навколишнього середовища <b>s_agrolab@vsau.vin.ua</b>\n"
+ "</p><p><br /> \n"
+ "</p>\n"
+ "<h2> <span class=\"mw-headline\" id=\"6._.D0.A4.D0.B0.D0.BA.D1.83.D0.BB.D1.8C.D1.82.D0.B5.D1.82_.D1.82.D0.B5.D1.85.D0.BD.D0.BE.D0.BB.D0.BE.D0.B3.D1.96.D1.97_.D0.B2.D0.B8.D1.80.D0.BE.D0.B1.D0.BD.D0.B8.D1.86.D1.82.D0.B2.D0.B0_.D1.82.D0.B0_.D0.BF.D0.B5.D1.80.D0.B5.D1.80.D0.BE.D0.B1.D0.BA.D0.B8_.D0.BF.D1.80.D0.BE.D0.B4.D1.83.D0.BA.D1.86.D1.96.D1.97_.D1.82.D0.B2.D0.B0.D1.80.D0.B8.D0.BD.D0.BD.D0.B8.D1.86.D1.82.D0.B2.D0.B0\"> 6. Факультет технології виробництва та переробки продукції тваринництва </span></h2>\n"
+ "<p>Кафедра фізичного виховання <b>physical_ad@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра годівлі с.г. тварин та водні біоресурси <b>feed_animals@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра розведення сільськогосподарських тварин та зоогігієни <b>zoohygiene@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра технології виробництва продуктів тваринництва <b>technol_livestock@vsau.vin.ua</b>\n\n"
+ "Кафедра харчових технологій та мікробіології <b>technol_proces@vsau.vin.ua</b>\n"
+ " \n"
+ "</p>\n"
+ "<h2> <span class=\"mw-headline\" id=\"7._.D0.A4.D0.B0.D0.BA.D1.83.D0.BB.D1.8C.D1.82.D0.B5.D1.82_.D0.BC.D0.B5.D1.85.D0.B0.D0.BD.D1.96.D0.B7.D0.B0.D1.86.D1.96.D1.97_.D1.81.D1.96.D0.BB.D1.8C.D1.81.D1.8C.D0.BA.D0.BE.D0.B3.D0.BE_.D0.B3.D0.BE.D1.81.D0.BF.D0.BE.D0.B4.D0.B0.D1.80.D1.81.D1.82.D0.B2.D0.B0\"> 7. Факультет механізації сільського господарства </span></h2>\n"
+ "<p>Кафедра двигунів внутрішнього згорання та альтернативних паливних ресурсів <b>comb_eng@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра експлуатації машино-тракторного парку та технічного сервісу <b>maint_serv@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра сільськогосподарських машин <b>agri_mach@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра машин та обладнання с.г. виробництва <b>mach_agri_product@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра процесів та обладнання переробних і харчових виробництв ім. проф. П.С. Берника <b>pocess_equipment@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра загально-технічних дисциплін та охорони праці <b>prof_education@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра електротехнічні системи, технології та автоматизація в АПК <b>el_sis@vsau.vin.ua</b>\n"
+ "</p><p><br /> \n"
+ "</p>\n"
+ "<h2> <span class=\"mw-headline\" id=\"8._.D0.A4.D0.B0.D0.BA.D1.83.D0.BB.D1.8C.D1.82.D0.B5.D1.82_.D0.BC.D0.B5.D0.BD.D0.B5.D0.B4.D0.B6.D0.BC.D0.B5.D0.BD.D1.82.D1.83_.D1.82.D0.B0_.D0.BF.D1.80.D0.B0.D0.B2.D0.B0\"> 8. Факультет менеджменту та права </span></h2>\n"
+ "<p>Кафедра аграрного менеджменту <b>agmen@vsau.vin.ua</b>\n"
+ "</p><p>Кафердра адміністративного менеджменту та альтернативних джерел енергії <b>altern_sources@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра дорадництва та інформаційних технологій в менеджменті <b>intehmen@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра загальнотеоретичних та правових дисциплін <b>general_leg@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра історії України та філософії <b>hist_phil@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра менеджменту зовнішньоекономічної діяльності, готельно-ресторанної справи та туризму <b>hotel_resr@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра публічно-правових дисциплін <b>right@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра української та іноземних мов <b>language@vsau.vin.ua</b>\n"
+ "</p>\n"
+ "<h2> <span class=\"mw-headline\" id=\"9._.D0.A6.D0.B5.D0.BD.D1.82.D1.80_.D0.B4.D0.BE.D0.B2.D1.83.D0.B7.D1.96.D0.B2.D1.81.D1.8C.D0.BA.D0.BE.D1.97_.D0.BF.D1.96.D0.B4.D0.B3.D0.BE.D1.82.D0.BE.D0.B2.D0.BA.D0.B8.2C_.D0.BF.D1.80.D0.B8.D0.B9.D0.BE.D0.BC.D1.83_.D0.BD.D0.B0_.D0.BD.D0.B0.D0.B2.D1.87.D0.B0.D0.BD.D0.BD.D1.8F_.D1.82.D0.B0_.D0.B2.D0.B8.D1.85.D0.BE.D0.B2.D0.BD.D0.BE.D1.97_.D1.80.D0.BE.D0.B1.D0.BE.D1.82.D0.B8\"> 9. Центр довузівської підготовки, прийому на навчання та виховної роботи </span></h2>\n"
+ "<p>Приймальна комісія <b>sel_com@vsau.vin.ua</b>\n"
+ "</p><p>Підготовче відділення <b>training@vsau.vin.ua</b>\n"
+ "</p><p>Відділ профорієнтаційної роботи <b>vocational@vsau.vin.ua</b>\n"
+ "</p><p>Відділ виховної роботи <b>ed_work@vsau.vin.ua</b>\n"
+ "</p><p><br /> \n"
+ "</p>\n"
+ "<h2> <span class=\"mw-headline\" id=\"10._.D0.91.D1.83.D1.85.D0.B3.D0.B0.D0.BB.D1.82.D0.B5.D1.80.D1.96.D1.8F\"> 10. Бухгалтерія </span></h2>\n"
+ "<p>Бухгалтерська служба <b>accounting@vsau.vin.ua</b>\n"
+ "</p><p>Планово-фінансовий відділ <b>plan_fin@vsau.vin.ua</b>\n"
+ "</p><p><br />\n"
+ "</p>\n"
+ "<h2> <span class=\"mw-headline\" id=\"11._.D0.86.D0.BD.D1.88.D1.96_.D1.81.D1.82.D1.80.D1.83.D0.BA.D1.82.D1.83.D1.80.D0.BD.D1.96_.D0.BF.D1.96.D0.B4.D1.80.D0.BE.D0.B7.D0.B4.D1.96.D0.BB.D0.B8\"> 11. Інші структурні підрозділи </span></h2>\n"
+ "<p>Загальний відділ <b>gen_div@vsau.vin.ua</b>\n\n"
+ "</p><p>Юридичний відділ <b>legal@vsau.vin.ua</b>\n"
+ "</p><p>Відділ кадрів <b>hum_res@vsau.vin.ua</b>\n"
+ "</p><p>Відділ аспірантури і докторантури <b>postgrad_doctoral@vsau.vin.ua</b>\n"
+ "</p><p>Відділ медіа та інформаційних ресурсів <b>media@vsau.vin.ua</b>\n"
+ "</p><p>Центр міжнародних звязків та діяльності <b>int_rel@vsau.vin.ua</b>\n"
+ "</p><p>Штаб цивільної оборони <b>civ_def@vsau.vin.ua</b>\n"
+ "</p><p>Кафедра військової підготовки <b>milit_train@vsau.vin.ua</b>\n"
+ "</p><p>Центр культури та дозвілля <b>leisure@vsau.vin.ua</b>\n"
+ "</p><p>Відділ з організації поселення і проживання студентів і аспірантів <b>settle@vsau.vin.ua</b>\n"
+ "</p><p>Обчислювальний центр <b>comp_cent@vsau.vin.ua</b>\n"
+ "</p><p>Бібліотека <b>libr@vsau.vin.ua</b>\n"
+ "</p><p>Науково-дослідний проектно-конструкторський технологічний інститут <b>srdit@vsau.vin.ua</b>\n"
+ "</p><p>Оператори ксерокопіювальних машин <b>xerox@vsau.vin.ua</b>\n"
+ "</p><p>Ботанічний сад <b>bot_gard@vsau.vin.ua</b>\n"
+ "</p><p>Центр здоровя <b>health@vsau.vin.ua</b>\n"
+ "</p><p>Їдальня <b>din_room@vsau.vin.ua</b>\n"
+ "</p><p>МТС \"Модуль\" <b>module@vsau.vin.ua</b>\n"
+ "</p><p>Центр адміністративно-господарської роботи <b>admin_centr@vsau.vin.ua</b>\n"
+ "</p><p><br />\n"
+ "</p>\n"
+ "<h2> <span class=\"mw-headline\" id=\"12._.D0.A6.D0.B5.D0.BD.D1.82.D1.80_.D0.BF.D1.96.D1.81.D0.BB.D1.8F.D0.B4.D0.B8.D0.BF.D0.BB.D0.BE.D0.BC.D0.BD.D0.BE.D1.97_.D0.BE.D1.81.D0.B2.D1.96.D1.82.D0.B8_.D1.82.D0.B0_.D0.B4.D0.BE.D1.80.D0.B0.D0.B4.D0.BD.D0.B8.D1.86.D1.82.D0.B2.D0.B0\"> 12. Центр післядипломної освіти та дорадництва</span></h2>\n"
+ "<p>Центр післядипломної освіти та дорадництва <b>div_post@vsau.vin.ua</b>\n"
+ "</p><p>Відділ післядипломної освіти та дорадництва <b>post_gr@vsau.vin.ua</b>\n"
+ "</p><p>Відділ підвищення кваліфікації <b>hi_train@vsau.vin.ua</b>\n"
+ "</p><p>Навчально-методична госпрозрахункова лабораторія з охорони праці <b>ss_lab@vsau.vin.ua</b>\n"
+ "</p><p><br /> \n"
+ "</p>\n"
+ "<h2> <span class=\"mw-headline\" id=\"13._.D0.9A.D0.BE.D0.BB.D0.B5.D0.B4.D0.B6.D1.96_.D0.92.D0.9D.D0.90.D0.A3\"> 13. Коледжі ВНАУ </span></h2>\n"
+ "<p>Вінницький технологічно-промисловий коледж \n"
+ "<b>tech_ind_college@vsau.vin.ua</b>\n"
+ "</p><p>Бухгалтерія вінницького технологічно-промислового коледжу\n"
+ "<b>accounting_tic@vsau.vin.ua</b>\n"
+ "</p><p>Брацлавський агроекономічний коледж\n"
+ "<b>brats_college@vsau.vin.ua</b>\n"
+ "</p><p>Могилів-Подільський технолого-економічний коледж\n"
+ "<b>mog_college@vsau.vin.ua</b>\n"
+ "</p><p>Немирівський коледж будівництва та архітектури\n"
+ "<b>nemir_college@vsau.vin.ua</b>\n"
+ "</p><p>Ладижинський коледж \n"
+ "<b>lad_college@vsau.vin.ua</b>\n"
+ "</p><p>Верхівський сільськогосподарський коледж\n"
+ "<b>verh_college@vsau.vin.ua</b>\n"
+ "</p><p>Чернятинський коледж\n"
+ "<b>chern_college@vsau.vin.ua</b>\n"
+ "</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}