$re = '/!(((?<!TOM[\s])\d+[.]?\d*)|(\d+[.]?\d*(?!\sTOM)))|(\d+)/m';
$str = '10.0 banana 30 apple 50 TOM 70 mango 100 peach 33 TOM 4.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);