$re = '/;|\b +\b/m';
$str = 'test DE; IT;ES ;CH;AU;FR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);