package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/(\w{5})\w*$`)
var str = `people/capital/base/flagedbyloggers`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}