package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^\+447|07|00447)\d{9}$`)
var str = `+447908846658
07908846658
00447908846658`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}