re = /(?:клиент|менеджер):\h*\K[^\h:]+/
str = 'клиент: красный менеджер: зеленый'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end