#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*<GetFulfillmentPreviewResponse[\s\S]*?>[\s\S]*?<GetFulfillmentPreviewResult[\s\S]*?>[\s\S]*?<FulfillmentPreviews[\s\S]*?<EstimatedFees[\s\S]*?<Value>([\s\S]*?)<\/Value>"
Local $sString = "<GetFulfillmentPreviewResponse xmlns="http://mws.amazonaws.com/FulfillmentOutboundShipment/2010-10-01/">" & @CRLF & _
" <GetFulfillmentPreviewResult>" & @CRLF & _
" <FulfillmentPreviews>" & @CRLF & _
" <member>" & @CRLF & _
" <MarketplaceId>ATVPDKIKX0DER</MarketplaceId>" & @CRLF & _
" <IsCODCapable>false</IsCODCapable>" & @CRLF & _
" <IsFulfillable>true</IsFulfillable>" & @CRLF & _
" <ShippingSpeedCategory>Standard</ShippingSpeedCategory>" & @CRLF & _
" <UnfulfillablePreviewItems/>" & @CRLF & _
" <EstimatedShippingWeight>" & @CRLF & _
" <Value>4</Value>" & @CRLF & _
" <Unit>POUNDS</Unit>" & @CRLF & _
" </EstimatedShippingWeight>" & @CRLF & _
" <EstimatedFees>" & @CRLF & _
" <member>" & @CRLF & _
" <Name>FBAPerUnitFulfillmentFee</Name>" & @CRLF & _
" <Amount>" & @CRLF & _
" <CurrencyCode>USD</CurrencyCode>" & @CRLF & _
" <Value>6.73</Value>" & @CRLF & _
" </Amount>" & @CRLF & _
" </member>" & @CRLF & _
" </EstimatedFees>" & @CRLF & _
" <FulfillmentPreviewShipments>" & @CRLF & _
" <member>" & @CRLF & _
" <LatestShipDate>2019-02-02T07:59:59Z</LatestShipDate>" & @CRLF & _
" <LatestArrivalDate>2019-02-05T07:59:59Z</LatestArrivalDate>" & @CRLF & _
" <FulfillmentPreviewItems>" & @CRLF & _
" <member>" & @CRLF & _
" <ShippingWeightCalculationMethod>Dimensional</ShippingWeightCalculationMethod>" & @CRLF & _
" <SellerFulfillmentOrderItemId>001test</SellerFulfillmentOrderItemId>" & @CRLF & _
" <EstimatedShippingWeight>" & @CRLF & _
" <Value>3.228</Value>" & @CRLF & _
" <Unit>POUNDS</Unit>" & @CRLF & _
" </EstimatedShippingWeight>" & @CRLF & _
" <Quantity>1</Quantity>" & @CRLF & _
" <SellerSKU>ASICS by Rakuten_20180926_29.86_6799</SellerSKU>" & @CRLF & _
" </member>" & @CRLF & _
" </FulfillmentPreviewItems>" & @CRLF & _
" <EarliestArrivalDate>2019-02-04T08:00:00Z</EarliestArrivalDate>" & @CRLF & _
" <EarliestShipDate>2019-01-29T08:00:00Z</EarliestShipDate>" & @CRLF & _
" </member>" & @CRLF & _
" </FulfillmentPreviewShipments>" & @CRLF & _
" </member>" & @CRLF & _
" </FulfillmentPreviews>" & @CRLF & _
" </GetFulfillmentPreviewResult>" & @CRLF & _
" <ResponseMetadata>" & @CRLF & _
" <RequestId>8a6d2844-317a-4bc7-9183-e405128203d9</RequestId>" & @CRLF & _
" </ResponseMetadata>" & @CRLF & _
"</GetFulfillmentPreviewResponse>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")