const regex = /Support Escalations*[\s\S]*Level IV.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Support Escalations*[\\s\\S]*Level IV.*', 'gm')
const str = `<td valign="top"><br>
<br>
John Doe<br>
Example, Inc. <br>
<br>
Office: 212.777.9999 x295<br>
jdoe@example.com| transbeam.com <br>
<br>
Support Escalations<br>
Level I: NOC Technician - support@example.com | O: 989.571.1000<br>
Level II: Manager, Network & Eng Operations, William Tell - wchen@example.com | O: 212.777.9999 x123 | M: 989.265.9876<br>
Level III: Vice President, Operations, Blaise Pascal - blaisep@example.com | O: 212.777.9999 x234 | M: 343.301.2822 <br>
Level IV: Chief Operating Officer: BF Skinner - bskinner@example.com | O: 212.777.9999 x345 | M: 343.337.7775<br>
<br>
<br>
<br>
From: Example Tech Support <br>
Sent: Monday, August 7, 2017 3:27 PM<br>
To: Example Tech Support <support@example.com>; 'nocdata@sample.com' <nocdata@sample.com><br>
Subject: RE: 81434 | WIN - Reparian Riverfront - EoC 10MB - Partial Impact<br>
<br>
Sample Support,<br>
<br>
Please be advised all loops have been repaired for this customer and they are currently up at their Full Bandiwdth.<br>
As this is stable, We will close this ticket out.<br>
<br>
Please let us know if you have any questions.<br>
<br>
Thank you,<br>
<br>
John Doe<br>
Example, Inc. <br>
<br>
Office: 212.777.9999 x295<br>
jdoe@example.com| transbeam.com <br>
<br>
Support Escalations<br>
Level I: NOC Technician - support@example.com | O: 989.571.1000<br>
Level II: Manager, Network & Eng Operations, William Tell - wchen@example.com | O: 212.777.9999 x123 | M: 989.265.9876<br>
Level III: Vice President, Operations, Blaise Pascal - blaisep@example.com | O: 212.777.9999 x234 | M: 343.301.2822 <br>
Level IV: Chief Operating Officer: BF Skinner - bskinner@example.com | O: 212.777.9999 x345 | M: 343.337.7775<br>
<br>
<br>
<br>
From: Example Tech Support <br>
Sent: Thursday, August 3, 2017 9:24 AM<br>
To: Example Tech Support <support@example.com>; 'nocdata@sample.com' <nocdata@sample.com><br>
Subject: RE: 81434 | WIN - Reparian Riverfront - EoC 10MB - Partial Impact<br>
<br>
Correction. The commit on the new ticket (loop 4) is 08/16. Apologies for the error.<br>
<br>
-------------------------------------<br>
Judy Garland<br>
NOC Technician<br>
<br>
From: Example Tech Support <br>
Sent: Thursday, August 03, 2017 9:22 AM<br>
To: 'nocdata@sample.com'<br>
Cc: Example Tech Support<br>
Subject: 81434 | WIN - Reparian Riverfront - EoC 10MB - Partial Impact<br>
<br>
Hello,<br>
<br>
Update regarding results of ILEC dispatch to prem this date. ILEC technician repaired the loop that was down (loop 3), but another loop (loop 4) developed a problem while he was there and is now bouncing. Loop 4 has been removed from the efm-group to prevent it from affecting the circuit and a ticket opened with the ILEC for its repair (commit 08/14).<br>
<br>
At this time, the 10Mb circuit is up at 9.8Mbps on 3 loops.<br>
<br>
<br>
If you have any further questions, comments or concerns regarding this message, please contact Example NOC support as documented below.<br>
<br>
Thank you,<br>
<br>
-------------------------------------<br>
Judy Garland<br>
NOC Technician<br>
<br>
transbeam.com<br>
<br>
=======================================================================<br>
Support Escalations<br>
Level I: NOC Technician - support@example.com | O: 989.571.1000<br>
Level II: Manager, Network Operations, William Tell - wchen@example.com | O: 212.777.9999 x123 | M: 989.265.9876<br>
Level III: Vice President, Operations, Blaise Pascal - blaisep@example.com | O: 212.777.9999 x234 | M: 343.301.2822 <br>
Level IV: Chief Operating Officer: BF Skinner - bskinner@example.com | O: 212.777.9999 x345 | M: 343.337.7775<br>
<br>
</td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}