import Foundation
let pattern = #"(?s)new\sMyClass\((?:[^;n]|n(?:n|e(?:n|w(?:n|\s(?:n|An(?:ew\sAn)*(?:n|o(?:n|t(?:n|h(?:n|e(?:n|r(?:n|C(?:n|l(?:n|a(?:n|sn))))))))|e(?:n|w(?:n|\sn)))))))*(?:[^;en]|e(?:[^;nw]|w(?:[^;\sn]|\s(?:[^;An]|A(?:[^;n]|n(?:ew\sAn)*(?:[^;eno]|o(?:[^;nt]|t(?:[^;hn]|h(?:[^;en]|e(?:[^;nr]|r(?:[^;Cn]|C(?:[^;ln]|l(?:[^;an]|a(?:[^;ns]|s[^;ns]))))))))|e(?:[^;nw]|w(?:[^;\sn]|\s(?:[^;An]|A[^;n]))))))))))*(?:n(?:n|e(?:n|w(?:n|\s(?:n|An(?:ew\sAn)*(?:n|o(?:n|t(?:n|h(?:n|e(?:n|r(?:n|C(?:n|l(?:n|a(?:n|sn))))))))|e(?:n|w(?:n|\sn)))))))*(?:e(?:(?:w(?:\sA?)?)?|w\sAn(?:ew\sAn)*(?:o(?:t?|th(?:e?|er(?:C?|Cl(?:a?|as))))|e(?:w(?:\sA?)?)?)?))?)?\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# case 0
return new MyClass(constructor, options, ...);
# case 1
var mc = new MyClass();
# case 2
var mc = new MyClass(new AnotherClass());
# case 3
var amc = new MyClass(options, new AnotherClass(), ...);
# case 4
MyClass mc = new MyClass(
something
);
# case 8
MyClass mc = new MyClass(
something, new Render()
);
# case 5
MyClass mc = new MyClass(
new AnotherClass()
);
# case 6
MyClass mc = new MyClass(
options, new AnotherClass()
);
# case 7
var amc = new MyClass(new AnotherClass(), options, ...);
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)