$re = '/^(?<id>foo|bar)(?: (?&id))*$/m';
$str = 'Valid instances are:
foo
bar
foo foo
foo bar
foo foo bar
foo bar foo bar
Invalid instances:
foofoo bar
baz foo bar
foo bar baz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);