$re = '/\b((?![a|b]*aab)[a|b]*)\b/';
$str = 'aba aab abaaba abaaa cbaa abbaab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);