# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<span class=\"_c1 ei_card_subtitle _c1\">.*?([\dX]+).*?<\/span>"
test_str = "<body class=\"default-theme des-mat\" style=\"background: rgb(255, 255, 255);\"><div id=\"prpd\"></div><div class=\"\" id=\"mngb\"><div id=\"gb\" class=\"gb_T\"><div class=\"gb_nb gb_Lg gb_R gb_Kg gb_Og gb_T\" style=\"min-width: 241px;\"><div class=\"gb_oe gb_R gb_Lg gb_Bg\"><div class=\"gb_Q gb_R gb_S gb_Lg\"><span class=\"_c1 ei_card_subtitle _c1\">Name<br /> 713286XXX971 - 12021980</span>/div><div class=\"gb_Q gb_R\"><a class=\"gb_P\" data-pid=\"23\" href=\"https://mail.google.com/mail/?authuser=0\">Gmail</a></div><div class=\"gb_Q gb_R\"><a class=\"gb_P\" data-pid=\"2\" href=\"https://www.google.com/imghp?hl=en&authuser=0\">Images</a></div></div><div class=\"gb_Ec gb_Lg gb_R\" style=\"min-width: 120px;\"><div class=\"gb_fa\" id=\"gbsfw\" style=\"background-color:#eee;min-width:376px\"><iframe ng-non-bindable=\"\" frameborder=\"0\" hspace=\"0\" marginheight=\"0\" marginwidth=\"0\" scrolling=\"no\" style=\"width: 376px; height: 380px;\" tabindex=\"0\" vspace=\"0\" width=\"100%\" class=\"gb_9b\" allowtransparency=\"true\" aria-hidden=\"true\" id=\"I0_1523641321551\" name=\"I0_1523641321551\" src=\"https://notifications.google.com/u/0/widget?sourceid=243&hl=en&origin=https%3A%2F%2Fwww.google.com&uc=1&usegapi=1&jsh=m%3B%2F_%2Fscs%2Fabc-static%2F_%2Fjs%2Fk%3Dgapi.gapi.en.DgOlXVbWcXc.O%2Fm%3D__features__%2Frt%3Dj%2Fd%3D1%2Frs%3DAHpOoo-riybzrJ8O_UpInxWO1d1OWu1FtA#pid=243&_methods=onError%2ConInfo%2ChideNotificationWidget%2CpostSharedMessage%2Creauth%2CsetNotificationWidgetHeight%2CsetNotificationWidgetSize%2CswitchTo%2CnavigateTo%2CsetNotificationText%2CsetNotificationAnimation%2CgetNotificationText%2CvalidateUser%2C_ready&id=I0_1523641321551&_gfid=I0_1523641321551&parent=https%3A%2F%2Fwww.google.com&pfname=&rpctoken=13573360\"></iframe></div><div class=\"gb_da gb_9c gb_R\" id=\"gbwa\"><div class=\"gb_Qc\"><a class=\"gb_b gb_hc\" href=\"https://www.google.com/intl/en/options/\" title=\"Google apps\" aria-expanded=\"false\" role=\"button\" tabindex=\"0\"></a><div class=\"gb_wb\"></div></body>"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.