package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)kuro`)
var str = `kuroki`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}