re = /\[\[((foo))((?>[^\[\]]+|(?R))*)\]\]/m
str = 'text [[foo text ]]
text [[ text [[foo text ]] text ]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end