re = /<.*>/
str = 'Some text is here <some substring is here> and some more text is here, <another here for testing>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end