$re = '/<.*?>/';
$str = 'Some text is here <some substring is here> and some more text is here, <another here for testing>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);