package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<[^>]*>`)
var str = `Some text is here <some substring is here> and some more text is here, <another here for testing>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}