$re = '/(?<!\b)\*[a-zA-Z0-9_]+/m';
$str = '*start This is a *star word. Here is another *word with a star. not*astar but *i_am';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);