#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)Game\.of\.Thrones\.S08\.(1080p|720p).*"
Local $sString = "Game.of.Thrones.S06.720p.BluRay.x264-DEMAND" & @CRLF & _
"Game.of.Thrones.S06.1080p.BluRay.x264-DEMAND" & @CRLF & _
"Game.of.Thrones.S08.720p.BluRay.x264-DEMAND" & @CRLF & _
"Game.of.Thrones.S08.1080p.BluRay.x264-DEMAND" & @CRLF & _
"Game.of.Thrones.S08.MiX.XviD-VARGRP"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")