re = /(['])(?:(?=(\\?))\2.)*?\1/m
str = 'string1 = \'test\' and string2 = \'ajsijd\' '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end