#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bcontainer\W+(?:\w+\W+){1,6}?switcher\b"
Local $sString = "<ul class="secondary">" & @CRLF & _
"<li><a href="/all/">all code snippets</a>/</li>" & @CRLF & _
"<li><a href="/popular/">popular code snippets</a>/</li>" & @CRLF & _
"<li><a href="/yours/">your code snippets</a></li>" & @CRLF & _
"</ul>" & @CRLF & _
"</li>" & @CRLF & _
"<li class="developer">" & @CRLF & _
"<a href="/developer/">extras</a>" & @CRLF & _
"</li>" & @CRLF & _
"<li class="blog"><a href="/blog/">blog</a></li>" & @CRLF & _
"<li class="about"><a href="/about/">about snipplr</a></li>" & @CRLF & _
"</ul>" & @CRLF & _
"</div>" & @CRLF & _
"</div>" & @CRLF & _
"</div>" & @CRLF & _
"<div id="subnav">" & @CRLF & _
"<div class="container">" & @CRLF & _
"<div id="switcher">" & @CRLF & _
"<span>Change style:</span>" & @CRLF & _
"<ul>" & @CRLF & _
"<li><a class="styleswitch" href="#" onclick="setActiveStyleSheet('big'); return false;">Big</a> / </li>" & @CRLF & _
"<li><a class="styleswitch" href="#" onclick="setActiveStyleSheet('small'); return false;">Small</a></li>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")