$re = '/(?<=START)(?:(?!START).)*(?=END)/m';
$str = '"END START START bad result START good result 1 END START good result 2 END START START"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);