$re = '/^(?:\S+\h+){3}\K\d{4}\b/m';
$str = 'LIEA 051550Z 21005KT 9999 FEW020 19/14 Q1011
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);