re = /^(?=.{8,22}$)(?!.*(.)\1{2})(?=(?:\D*\d){2})(?=[^A-Z]*[A-Z])(?=[^a-z]*[a-z])[a-zA-Z].*$/m
str = 'asasas4aS5as.
asasaaa4aS5a
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end