re = /(?<= )[a-zA-Z][a-zA-Z ]*(?=,| )/m
str = 'St. Washington, 80
7-th mill B.O., 34
Pr. Lakeview, 17
Pr. Harrison, 15 k.1
St. Hillside Avenue, 26'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end