package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[1-3-6-9]`)
var str = `123456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}