re = /(?<=\/)(?<theWord>\w+)$/m
str = 'https://hostname/bs/cf/webservice/WordtoExtract'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end