$re = '/\bs\.l\.(?!\w)/';
$str = 'aaa s.l. bbb
aaa s.l.bbb
aaa s.l., bbb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);