$re = '/[0-9]{4}$/m';
$str = '123456785267';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);