#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(.*)(<strong>Характеристики<\/strong>.*<table>.*<\/table>)"
Local $sString = "Бензопила ланцюгова Vitals BKZ 5223n призначена для швидкого і ефективного обрізання кущів і гілок в садку, а також спилювання дерев та розпилювання їх на колоди. Даний виріб поєднує в собі високу якість, надійність у роботі, простоту в процесі експлуатації й обслуговування.<br><br>Бензопила ланцюгова Vitals BKZ 5223n володіє оновленим унікальним дизайном, має високоякісний корпус з поліаміду. Картер у цій моделі - алюмінієвий з додатковим захистом.<br><br>Дана модель оснащена економічним двотактним бензиновим двигуном потужністю 2,7 к.с. і максимальною частотою обертання колінчастого вала 11000 об/хв. Колінчастий вал у цій пили - посилений, що забезпечує тривалу безперебійну роботу двигуна. У свою чергу високоякісний карбюратор дозволяє легко запускати мотор пили і робити її роботу стабільнішою.<br><br>Для швидкого запуску двигуна (у тому числі і в холодну пору року) використовується паливопідкачувальний насос «праймер». Що примітно, повітряна заслінка під час натискання на важіль дроселя відкривається автоматично. Для більш ефективного відведення відпрацьованих газів конструкцією глушника передбачені дві вихлопні труби, що сприяє збільшенню працездатності двигуна. Для ефективної фільтрації в цій моделі Бензопили ланцюгові використовується високоякісний паперовий фільтр. Доступ до фільтру - безключовий, що дуже зручно під час технічного обслуговування виробу.<br><br>Примітно, що бензопила ланцюгова Vitals BKZ 5223n має функцію «Легкий старт». Завдяки цій системі зусилля, яке прикладається користувачем під час запуску двигуна Бензопили ланцюгові, знижено на 30%. Таким чином, немає необхідності смикати стартер, достатньо лише плавно витягнути мотузку.<br><br>На виріб встановлені 18-дюймова шина з ланцюгом високої якості. Даний показник довжини шини прийнято вважати ідеальним для виконання робіт у побуті, в тому числі із деревиною великого діаметру. Завдяки швидкості ланцюга, що дорівнює 18,0 м/с, забезпечується висока продуктивність роботи.<br><br>Щоб уникнути перегрівання та запобігти корозії і передчаснму зношенню шини та ланцюга, конструкцією передбачена ефективна система автоматичного змащування. Кількість масла, яке подається на шину і ланцюг, залежить від попереднього регулювання масляного насоса. Для швидкої і зручної установки і натягу ланцюга використовується механізм натягу в бічному виконанні. Ведуча зірочка - знімна, завдяки чому забезпечується швидка її заміна або ремонт.<br><br>З метою безпечної експлуатації конструкцією передбачений ефективне гальмо ланцюга з часом спрацьовування 0,12 с. У разі віддачі або «зворотного удару» гальмо ланцюга спрацьовує дуже швидко, обертання ланцюга при цьому відразу припиниться.<br><br>Для зниження рівня вібрації застосована сучасна антивібраційна система - спеціальні демпферні опори, які ефективно поглинають вібрацію, захищаючи тим самим руки користувача від її негативного впливу.<br><br>Варто відзначити, що в моделі Vitals BKZ 5223n використовуються виключно високоякісні комплектуючі, які гарантують надійність і довговічність експлуатації виробу. Стінки циліндра у пили - хромовані. Таким чином буде забезпечений тривалий термін служби двигуна завдяки збільшенню зносостійкості циліндро-поршневої групи.<br><br>На всі частини і деталі інструмента поширюється абсолютна гарантія 12 місяців, яка діє на всій території України.<br><br><br><strong>Особливості:</strong> <br><br> <br> <ul><li>алюмінієвий картер двигуна високої якості з додатковим захистом;</li><li>високоефективний паперовий повітряний фільтр – для максимального очищення повітря, що надходить у карбюратор;</li><li>посилений колінвал забезпечує безперебійну роботу двигуна;</li><li>знімна ведуча зірочка забезпечує швидкий ремонт або заміну зірочки;</li><li>легкий старт - зусилля, яке прикладається користувачем під час запуску двигуна Бензопили ланцюгові, знижено на 30%;</li><li>високоякісний карбюратор забезпечує легкий запуск і стабільну роботу пили;</li><li>хромоване покриття стінок циліндра забезпечує підвищену зносостійкість під час роботи циліндропоршневої групи;</li><li>механізм натягу ланцюга розташований збоку – значно полегшує регулювання натягу ланцюга;</li><li>оновлений унікальний дизайн;</li><li>безключний доступ до повітряного фільтра;</li><li>2 компресійних кільця;</li><li>сучасна антивібраційна система;</li><li>регульований маслонасос;</li><li>високоміцний якісний корпус із поліаміду;</li><li>ефективне гальмо ланцюга - час спрацьовування гальма ланцюга становить лише 0,12 с!;</li><li>висока швидкість ланцюга забезпечує високу продуктивність роботи;</li><li>шина і ланцюг високої якості.</li></ul> <br> <br><br> <strong>Характеристики</strong> <br><br> <table> <tbody><tr> <td><strong>Тип двигуна</strong></td> <td>двотактний бензиновий одноциліндровий, повітряного охолодження</td> </tr> <tr> <td><strong>Тип палива</strong></td> <td>суміш бензину з маслом для двотактних двигунів 25:1</td> </tr> <tr> <td><strong>Робочий об'єм циліндра, куб. см</strong></td> <td>52</td> </tr> <tr> <td><strong>Потужність, к.с. / кВт</strong></td> <td>2,7 / 2,0</td> </tr> <tr> <td><strong>Максимальна швидкість, об/хв</strong></td> <td>11000</td> </tr> <tr> <td><strong>Швидкість холостого ходу, об/хв</strong></td> <td>3000</td> </tr> <tr> <td><strong>Швидкість ланцюга, м/c</strong></td> <td>18</td> </tr> <tr> <td><strong>Час спрацьовування гальма ланцюга, с</strong></td> <td>0,12</td> </tr> <tr> <td><strong>Об'єм паливного бака, мл</strong></td> <td>600</td> </tr> <tr> <td><strong>Об'єм масляного бака, мл</strong></td> <td>260</td> </tr> <tr> <td><strong>Довжина шини, дюйм</strong></td> <td>18</td> </tr> <tr> <td><strong>Крок ланцюга, дюйм</strong></td> <td>0,325</td> </tr> <tr> <td><strong>Габарити упаковки, мм</strong></td> <td>520х330х320</td> </tr> <tr> <td><strong>Вага нетто/брутто, кг</strong></td> <td>6,5/7,0</td> </tr> </tbody></table> <br>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")