import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(<strong>Характеристики<\\/strong>.*<table>.*<\\/table>)";
final String string = "Кутова Шліфувальна машина Vitals Master Ls 1272HL - легка і надійна напівпрофесійна модель, яка здатна в умовах безперервної та інтенсивної роботи виконувати різного роду завдання, як на невеликому виробництві, так і в домашніх умовах. Відмінною особливістю даної моделі є те, що даний виріб має спеціальний малогабаритний корпус, що дозволяє комфортно працювати однією рукою. <br><br> <br><br> Модель Vitals Master Ls 1272HL, потужність якої становить 720 Вт, характеризується високою ефективністю і зручністю роботи, а також експлуатаційної надійністю і простотою обслуговування. Виріб має високу постійну швидкість обертання холостого ходу, рівну 11000 об / хв. В роботі можуть використовуватися відрізні (шліфувальні) кола з максимальним діаметром 125 мм. <br><br> <br><br> Головними конкурентними перевагами даного електроінструмента є надійний електродвигун, а також якісні комплектуючі, що в рази збільшують термін його експлуатації. Корпус кутової шліфувальної машини Ls 1272HL виготовлений з високоякісного пластику. Важливою особливістю цієї моделі є те, що замість втулок ковзання в конструкції використовуються кулькові підшипники. <br><br> <br><br> Комплектується кутова Шліфувальна машина додатковим руків 'ям, захисним кожухом, вугільними щітками, а також ключем для надійної фіксації відрізного (шліфувального) кола. <br><br> <br><br> Вага виробу складає всього 2,0 кг, що в поєднанні з компактним і ергономічним дизайном робить цей електроінструмент зручним і безпечним в процесі експлуатації <br><br><br><ul> <li> надійний електродвигун; </li> <li> якісні підшипники замість втулок ковзання; </li> <li> фіксовані Положення клавіші \". вкл. / викл\"; </li> <li> знижена вібраційна навантаження; </li> <li> підвищена зносостійкість деталей і вузлів; </li> <li> корпус виготовлено з високоякісного пластику; </li> <li> висока ефективність і зручність роботи; </li> <li> швидкий доступ до вугільних щіток; </li> <li> експлуатаційна надійність і простота обслуговування. </li></ul>\n"
+ " <strong>Характеристики</strong><br><br><table> <tbody> <tr> <td><strong>Напруга, В</strong></td> <td>230</td> </tr> <tr> <td><strong>Частота струму, Гц</strong></td> <td>50</td> </tr> <tr> <td><strong>Потужність, Вт</strong></td> <td>720</td> </tr> <tr> <td><strong>Частота обертів холостого ходу, об/хв</strong></td> <td>11000</td> </tr> <tr> <td><strong>Регулювання швидкості</strong></td> <td>-</td> </tr> <tr> <td><strong>Плавний пуск</strong></td> <td>-</td> </tr> <tr> <td><strong>Максимальний діаметр диска, мм</strong></td> <td>125</td> </tr> <tr> <td><strong>Габарити упаковки, мм</strong></td> <td>315х90х120</td> </tr> <tr> <td><strong>Маса нетто/брутто, кг</strong></td> <td>2,0/2,4</td> </tr> </tbody> </table> <br>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}