re = /(\w+)=([^\s]+)/
str = 'metadata=1.2 name=stone:supershare UUID=eff4e7bc:47aea5cf:0f0560f0:2de38475'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end