re = /"authorization\\\":\\\"([^\\\"]+)"/
str = ',\\\\\\"authorization\\\\\\":\\\\\\"xxxxxx.yyyyy.fff-dddd\\\\\\",'
# Print the match result
str.match(re) do |match|
puts match.to_s
end