package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)\.(\d+)$`)
var str = `iso.3.6.1.4.1.2011.6.128.1.1.2.21.1.6.4194455040`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}