re = /^([A-Z][a-z]* )*[A-Z]$/m
str = 'Match
Example Name A
A New Example C
No match
a Test B
Wrong Name
Another_Wrong_Name A
Nop3 A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end