$re = '/^[a-zA-Z0-9._@]{2,}[a-zA-Z0-9]$/m';
$str = 'abc@
abc.
@@a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);