$re = '/[A-Z]{3}(?<![A-Z]{4})(?![A-Z])/';
$str = 'bcAc BDBGFeQFFJaaBx EBBcDDD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);