package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.\d[0-9]{0,8}`)
var str = `.231456342555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}