$re = '/\b\d+(?=[A-Z])/m';
$str = 'K2SO4 + Cr2(SO4)3 + (NH4)2SO4 + H2O';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);