const regex = /今日は(?<weather>(?!豪).+)だった。/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('今日は(?<weather>(?!豪).+)だった。', 'gm')
const str = `今日は雨だった。
今日は豪雨だった。
今日は晴れだった。
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}