const regex = new RegExp('^(?:(?:1?[1-9]?\\d|[12][0-4]\\d|25[0-5])(?:\\.(?!$)|$)){4}$', 'gm')
const str = `123.1.2.3
123.1.1.1.1
266.1.1
00.1.1.1
1234.1.1.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}