import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(([^\\)]*)\\) started playing ([^\\.-]*\\b)( - ([^\\.]+))?\\.";
final String string = "hyper_d (Galaxy S9) started playing King of the Hill - Episode 419.\n\n"
+ "hyper_d (Galaxy S9) started playing Mr. & Mrs. Smith.\n\n"
+ "hyper_d (Galaxy S9) started playing Kick-Ass.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}